Back to overview
Resolved
Degraded performance
Sep 3, 2026 at 9:55pm UTC
Affected services
Fieldguide US Application
Resolved
Sep 3, 2026 at 10:20pm UTC
We're seeing AWS recover. Our team is continuing to monitor this event.
Affected services
Created
Sep 3, 2026 at 9:55pm UTC
Amazon Web Services (AWS) is reporting degraded performance. Due to this, we're seeing higher than normal errors rates for some services. Our team is monitoring this situation and coordinating with AWS.
Affected services