Back to overview
Resolved

Document processing delays

Sep 14, 2026 at 4:30pm UTC
Affected services
Fieldguide AI

Resolved
Sep 14, 2026 at 6:00pm UTC

Document processing has returned to normal. We're continuing to monitor as our queue finishes processing our backlog.

Created
Sep 14, 2026 at 4:30pm UTC

We're investigating issues with document processing that are resulting in delayed content extraction. Our team is investigating this and will provide updates.