Get in touch
Back
Maintenance

Routine Maintenance - System Upgrade

Completed 19 Mar at 02:00am UTC.

Fieldguide US Application Fieldguide CA Application
Completed

Maintenance completed

Posted 19 Mar at 02:00am UTC.
Started

Our team is performing a routine system upgrade on 3/18/2024 from 9:00pm Eastern to 10:00pm Eastern. There may be a short period of elevated error rates around login during this time.

Posted 19 Mar at 01:00am UTC.