Get in touch
Back
Degraded

Degraded performance on the Fieldguide application

Started 16 Sep at 04:19pm UTC, resolved 16 Sep at 04:40pm UTC.

Fieldguide US Application
Resolved

Our team is seeing services operate normally. We're continuing to monitor this event.

Posted 16 Sep at 04:40pm UTC.
Created

We're currently investigating slow performance and intermittent availability issues of the Fieldguide application. Our team is reviewing and will update this page.

Posted 16 Sep at 04:19pm UTC.