Get in touch
Back
Degraded

Sporadic service disruptions from DNS provider

Started 5 Feb at 03:30pm UTC, resolved 5 Feb at 04:30pm UTC.

Fieldguide US Application
Resolved

This incident has been resolved.

Posted 5 Feb at 04:30pm UTC.
Created

We're currently monitoring sporadic performance and availability issues with our DNS provider, Cloudflare, impacting a small percentage of overall traffic. Due to this, users may encounter sporadic issues when loading the Fieldguide application.

Posted 5 Feb at 03:30pm UTC.