Back
Maintenance

Routine Maintenance - System Upgrade
Completed 14 Mar at 01:00am UTC.
Fieldguide US Application
Fieldguide US Document Sync Service
Fieldguide CA Application
Fieldguide CA Document Sync Service
Fieldguide EU Application
Fieldguide EU Document Sync Service
Fieldguide AI
Completed
Maintenance completed
Posted
14 Mar at 01:00am UTC.

Started
Our team is performing a routine system upgrade on March 13, 2025 from 8:00 PM EDT to 9:00 PM EDT. While we do not expect any impact to your usage of Fieldguide during this window, there may be periods of increased error rates.
Posted
14 Mar at 12:00am UTC.