Back
Maintenance

Routine Maintenance - System Upgrade
Completed 8 Apr at 01:30am UTC.
Fieldguide US Application
Fieldguide CA Application
Fieldguide EU Application
Completed
Maintenance completed
Posted
8 Apr at 01:30am UTC.

Started
Our team is performing a routine system upgrade on Monday, April 7, 2025 from 8:00 PM EDT to 9:30 PM EDT. While we do not expect any impact to your usage of Fieldguide during this window, there may be periods of increased error rates.
Posted
8 Apr at 12:00am UTC.