Back to overview
Resolved

Degraded performance

Jul 20, 2026 at 5:45pm UTC
Affected services
Fieldguide US Application
Fieldguide CA Application
Fieldguide EU Application
Fieldguide AP Application

Resolved
Jul 20, 2026 at 5:54pm UTC

We're continuing to monitor this incident, but are seeing services recover.

Created
Jul 20, 2026 at 5:45pm UTC

Our team is investigating reports of degraded performance.